Was gelernt



Ich hab ja seit einiger Zeit ein OnePlus One als Handy. Einstmals fast noch als „Prügel“ verschrien, hat heute selbst der Kollege, der damals meinte, so ein Riesenteil käme ihm niemalsnienicht in die Tasche, ein Gerät ähnlichen Ausmaßes.
Ich vermisse auch heute noch nichts großartiges. Die Kamera an dem Gerät ist nach wie vor gut, der Prozessor ist schnell genug, um zum Beispiel PhotoSpheres in annehmbarer Zeit zu berechnen, 64GB Speicher und FullHD Quer (1080×1920) auf dem Display sind auch heute noch chic.
Das Einzige, was mir in letzter Zeit missfiel, ist, dass es keine Sicherheits-Updates mehr gab. Von OnePlus gäbe es zwar mit OxygenOS eine nach wie vor weiter gepflegte Android-Geschmacksrichtung, aber die Firma hinter meinem original installierten OS, Cyanogen Inc., ist den Weg sehr vieler Startups gegangen; auch die wohl berühmteste Alternativ-Firmware CyanogenMod gibt es nicht mehr.
Mit LineageOS (sprich: Linni-itsch-Ou-Es) gibt es jedoch einen würdigen Nachfolger. Und den hab ich mir gestern aufs Gerät getüdelt. Im Prinzip hat alles funktioniert wie in der Anleitung beschrieben, aber über ein paar Dinge bin ich dann doch kräftig gestolpert:

  • TWRP ging bei mir erst, nachdem ich die Option „Update Recovery“ im Entwicklermenü abgeschaltet hatte
  • Mit TWRP 3.1.1-0 (die seit 19. Mai aktuelle Version) bekam ich kein Lineage-Zip geflasht. Damit hagelte es reproduzierbar nur Fehler „E3003 Can’t install this package over newer build“
  • die OpenGApps bekam ich aus irgendwelchen Gründen nur in der Nano-Variante aufs Gerät, bei größeren Paketen gab es auch irgendein Speicherplatzproblem
  • Whatsapp und Threema Backuppen und Wiederherstellen ist nicht trivial und bedarf einiger FAQ-Studien und Vorbereitung. Bei Threema gibt’s ja wenigstens entsprechende Menüpunkte.

20170520_lineageinstallation.jpg

Aber immerhin hab ich jetzt ein aktuelles Android 7.1.2 statt 6-Punkt-Irgendwas auf dem Handy!

Edit: Foto von der Fehlermeldung hinzugefügt. Nach etwas Überlegen könnte der Fehler möglicherweise dadurch verursacht worden sein, dass TWRP am 19.5. aktualisiert wurde, aber mein Nightly vom 15.5. war.

Sonntag, 21. Mai 2017 by Wolfram
Kommentar hinzufügen (4836 views)